Cloudflare System Status

ZT Customers with EDNS Enabled receiving incorrect IPs

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 23:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2025 - 23:32 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 04, 2025 - 19:05 UTC

Investigating

We are investigating an issue where customers with EDNS enabled may receive IPs as a DNS response pointing to destinations that are incorrect. If you have geo restrictions on where your Zero Trust users are allowed to go, this may result in your users getting blocked from accessing company resources.
Posted Mar 04, 2025 - 16:35 UTC
This incident affected: Cloudflare Sites and Services (Gateway, Zero Trust).