Cloudflare System Status

Network Performance Issues in Ashburn

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Nov 02, 2021 - 05:23 UTC

Investigating

Cloudflare is investigating issues with network performance in Ashburn, VA, United States.

We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Nov 02, 2021 - 05:08 UTC
This incident affected: North America (Ashburn, VA, United States - (IAD)).