Cloudflare System Status

Cloudflare Geo-Key Manager Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 03, 2023 - 11:01 UTC
Investigating
Cloudflare is investigating issues with Geo-Key Manager.
Some connections using Geo Key Manager may result in failed request TLS handshakes.
Connections not using Geo Key Manager are unaffected.
We are working to mitigate this problem.
More updates to follow shortly.
Posted May 03, 2023 - 09:10 UTC
This incident affected: Cloudflare Sites and Services (Geo-Key Manager).