Cloudflare System Status

Compressible responses from workers sometimes being sent uncompressed

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Oct 26, 2025 - 08:21 UTC

Identified

In some circumstances, Cloudflare will return uncompressed HTTP content for responses from Cloudflare workers, even when the "Accept-Encoding" header has been sent. Cloudflare engineering is engaged and rolling out a fix.
Posted Oct 24, 2025 - 00:00 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache, Workers).