Cloudflare System Status

Cache Purge Delay when using Cache Reserve

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 23:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2025 - 22:34 UTC

Identified

Cloudflare cache purging by prefix is delayed when using Cache Reserve. We have identified the problematic release and are reverting now. Until then you may use the Purge by URL feature. More updates to follow.
Posted Apr 10, 2025 - 22:29 UTC
This incident affected: Cloudflare Sites and Services (CDN Cache Purge).