Cloudflare System Status

AWS S3 SDK compatibility inconsistencies with R2
Incident Report for Cloudflare
Update
We are continuing to work on a fix for this issue.
Posted Jan 17, 2025 - 11:23 UTC
Identified
AWS recently updated their SDKs to enable CRC32 checksums on multiple object operations by default.
R2 does not currently support CRC32 checksums, and the default configurations will return header related errors such as Header 'x-amz-checksum-algorithm' with value 'CRC32' not implemented.

Impacted users can either pin AWS SDKs to a prior version or modify the configuration to restore the prior default behavior of not checking checksums on upload.

For more details, see the examples section of the R2 Docs for the relevant SDK:
https://developers.cloudflare.com/r2/examples/aws/
Posted Jan 17, 2025 - 03:20 UTC
This incident affects: Cloudflare Sites and Services (R2).