Cloudflare System Status

SSL Certificate Provisioning Delays

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 15:45 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 19, 2025 - 08:29 UTC

Investigating

Cloudflare is investigating delays in provisioning Universal SSL certificates for Partial zones, Custom Hostname DNS-based rechecks and zone-level TLS settings.

SSL certificates already in production remain unaffected and are operating normally.
Posted Mar 19, 2025 - 07:12 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning, SSL for SaaS Provisioning).