Cloudflare System Status

Network Performance Issues in Mumbai, India area.

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 26, 2021 - 13:04 UTC

Investigating

Cloudflare is investigating issues with network performance in Mumbai, India area.

We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Apr 26, 2021 - 12:28 UTC
This incident affected: Asia (Mumbai, India - (BOM)).