Cloudflare System Status

Issues passing Challenge Pages and Turnstile
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 20, 2024 - 07:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2024 - 06:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 20, 2024 - 06:55 UTC
Investigating
Some visitors may have experienced issues passing Challenge Pages and Turnstile challenges from some browser. Users may have been unable to complete a challenge, resulting in failure to proceed.
Posted Sep 20, 2024 - 06:26 UTC
This incident affected: Cloudflare Sites and Services (Challenge Platform).