Cloudflare System Status

Custom Hostnames Service availability and high latency impact

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 18:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 17:59 UTC

Identified

Cloudflare is investigating an increased level of errors for customers using the Custom Hostnames API.
Posted Mar 20, 2025 - 17:52 UTC
This incident affected: Cloudflare Sites and Services (SSL for SaaS Provisioning).