Cloudflare System Status

Forgot Email Portal Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 14, 2023 - 23:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2023 - 22:59 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 14, 2023 - 22:54 UTC
Investigating
Cloudflare is investigating an issue with the Forgot Email Portal. Self-serve customers may experience difficulties recovering account login email address.
Posted Jun 14, 2023 - 22:25 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).