Cloudflare System Status

Increased HTTP/3 request timeouts with Google Chrome
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Aug 17, 2023 - 04:04 UTC
Identified
We are rolling back a release to remediate the issue with HTTP/3.
Posted Aug 16, 2023 - 23:36 UTC
Investigating
Cloudflare is investigating an issue where HTTP/3 requests may occasionally stall on Google Chrome. Customers with HTTP/3 enabled may see requests timing out under certain circumstances.
Posted Aug 16, 2023 - 21:59 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache).