Cloudflare System Status

Issues with IP Geolocation
Incident Report for Cloudflare
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 21, 2024 - 10:18 UTC
Investigating
Cloudflare is investigating an issue with geolocation reporting. Customers may see stale data in geolocation reports
Posted Nov 21, 2024 - 10:12 UTC