Cloudflare System Status

Cloudflare Billing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 11, 2024 - 05:32 UTC
Investigating
Cloudflare is investigating an issue where some customers may see duplicated charges. All other services are operating normally.

We will provide an update once more information becomes available.
Posted Sep 11, 2024 - 04:10 UTC
This incident affected: Cloudflare Sites and Services (Billing).