Cloudflare System Status

WARP connectivity

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 13:27 UTC

Monitoring

Impact ended at 06:45 UTC, and we are monitoring the situation.
Posted Apr 20, 2026 - 10:21 UTC

Update

We are continuing to investigate this issue.
Posted Apr 20, 2026 - 00:53 UTC

Investigating

Cloudflare is investigating issues with Cloudflare WARP and Cloudflare Zero Trust. Cloudflare WARP and Zero Trust users may experience connectivity issues or a degraded Internet experience.
Posted Apr 18, 2026 - 16:36 UTC
This incident affected: North America (Dallas, TX, United States - (DFW)) and Cloudflare Sites and Services (Zero Trust).