Cloudflare System Status

Increase of delayed deliveries for Cloudflare transactional emails

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 14:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2025 - 14:28 UTC

Investigating

Cloudflare is observing an increased delay in the delivery of transactional emails to specific email providers. This does not affect any Cloudflare Email Security products. We are currently investigating this issue.
Posted Feb 04, 2025 - 14:06 UTC