Cloudflare System Status

SSL Certificate Validation Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 08:20 UTC
Investigating
Cloudflare is investigating delays in SSL certificate validation. New SSL certificate validation is taking longer than usual.

SSL certificates already in production remain unaffected and are operating normally.
Posted Apr 06, 2023 - 07:49 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).