Cloudflare System Status

Cloudflare WAF False Positives

Incident Report for Cloudflare

Resolved

This issue is now resolved.
Posted Apr 01, 2025 - 19:42 UTC

Monitoring

We have disabled the rule in question, and the rate of false positives is decreasing. We are monitoring.
Posted Apr 01, 2025 - 17:31 UTC

Identified

Cloudflare has identified an issue with the managed ruleset "Apache Camel - Remote Code Execution - CVE:CVE-2025-29891" which is potentially causing false positives. Customers can disable this rule by setting Action -> Log in the Cloudflare Dashboard. Other WAF rules are unaffected. We are currently working on a fix for this issue.
Posted Apr 01, 2025 - 17:03 UTC
This incident affected: Cloudflare Sites and Services (Firewall).