Cloudflare System Status

Network Performance Issues in Seattle, Washington(SEA)
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Dec 14, 2023 - 00:43 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 13, 2023 - 22:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 13, 2023 - 21:35 UTC
Investigating
Customers reaching the Seattle, Washington datacenter may experience network performance issues.
Posted Dec 13, 2023 - 21:02 UTC
This incident affected: North America (Seattle, WA, United States - (SEA)).