Cloudflare System Status

Billing Email Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 20, 2024 - 21:48 UTC
Investigating
We are currently investigating an issue that may have caused some users to receive billing emails in error. Our team is actively reviewing the situation and working to resolve it as quickly as possible. We will provide an update shortly.
Posted Sep 20, 2024 - 17:16 UTC
This incident affected: Cloudflare Sites and Services (Billing).