Cloudflare System Status

Wrangler Installation Issue

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jan 11, 2025 - 18:07 UTC

Monitoring

New installs are working again. We are continuing to monitor for any further issues.
Posted Jan 11, 2025 - 17:59 UTC

Update

To workaround the issue, affected users can pin the 'readdirp' transitive dependency to a version earlier than 4.1 via npm/pnpm overrides, and additionally in Worker projects created by Wrangler.
Posted Jan 11, 2025 - 17:43 UTC

Identified

Cloudflare is aware of and investigating an issue with new Wrangler installs failing, because of a change in a dependency. An update with the fix is being made.
Posted Jan 11, 2025 - 17:36 UTC
This incident affected: Cloudflare Sites and Services (Wrangler).