Cloudflare System Status

Cloudflare Zero Trust dashboard: Custom Pages - block

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 15, 2025 - 15:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 15, 2025 - 15:00 UTC

Investigating

Cloudflare is investigating issues with the Zero Trust dashboard. Customers are unable to set a Custom block page.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Mar 15, 2025 - 03:48 UTC
This incident affected: Cloudflare Sites and Services (Zero Trust Dashboard).