Cloudflare System Status

Network Performance issue in Hong Kong

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 02:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2025 - 02:34 UTC

Investigating

Cloudflare is investigating network performance issue in Hong Kong. Users might be experiencing elevated error rates and connection timeout issues.

We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Mar 12, 2025 - 02:31 UTC
This incident affected: Asia (Hong Kong - (HKG)).