Cloudflare System Status

Issues enabling Email Routing
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 09, 2024 - 22:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2024 - 21:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 09, 2024 - 21:43 UTC
Investigating
Cloudflare is investigating an issue where users cannot enable Email Routing.
Posted Oct 09, 2024 - 21:42 UTC
This incident affected: Cloudflare Sites and Services (Email Routing).