Cloudflare System Status

Issues with Billable Usage Notifications

Incident Report for Cloudflare

Resolved

After further investigation, we confirmed that there was no widespread issue affecting usage-based billing alerts. As a result, this incident has been canceled.
Posted Apr 09, 2025 - 10:35 UTC

Investigating

Cloudflare is currently experiencing issues processing alerts related to Billable Usage.

We will share an update as soon as this billing service returns to normal.
Posted Apr 09, 2025 - 09:23 UTC
This incident affected: Cloudflare Sites and Services (Billing, Notifications).