Cloudflare System Status

Universal SSL Certificate Provisioning Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 04, 2024 - 22:02 UTC
Update
We are continuing to work on a fix for this issue. At the present time, engineering is processing a backlog of certificate orders. Further updates will be posted when they have been made available.
Posted Jul 04, 2024 - 19:12 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 04, 2024 - 14:36 UTC
Investigating
Cloudflare is investigating delays in provisioning Universal SSL certificates.

SSL certificates already in production remain unaffected and are operating normally.
Posted Jul 04, 2024 - 13:13 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).