Cloudflare System Status

Network Performance Issues in Seoul

Incident Report for Cloudflare

Resolved

This incident has been resolved.

Customer impact was in-between 6:00 and 6:15.
Posted 15 days ago. Mar 20, 2025 - 06:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 15 days ago. Mar 20, 2025 - 06:51 UTC

Investigating

Cloudflare is investigating issues with Network Performance in Seoul, South Korea (ICN).

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted 15 days ago. Mar 20, 2025 - 06:00 UTC
This incident affected: Asia (Seoul, South Korea - (ICN)).