Cloudflare System Status

Increased Reports of ERR_SSL_VERSION_OR_CIPHER_MISMATCH
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 05, 2023 - 22:58 UTC
Identified
Cloudflare has identified the root cause and is rolling out a fix.
Posted Oct 05, 2023 - 22:10 UTC
Investigating
Cloudflare is investigating increased reports for ERR_SSL_VERSION_OR_CIPHER_MISMATCH
Posted Oct 05, 2023 - 21:55 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache).