Cloudflare System Status

Issues with Cached Resources in the London Region

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 15:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2025 - 15:11 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 05, 2025 - 14:58 UTC

Investigating

Cloudflare is aware of and investigating isolated cases where cached resources are incorrectly served after purging actions were performed in London region.
Posted Mar 05, 2025 - 14:38 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache) and Europe (London, United Kingdom - (LHR)).