Cloudflare System Status

Network Performance Issues for some customers in Virginia area

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 21:19 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2025 - 21:14 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 27, 2025 - 20:58 UTC

Investigating

Cloudflare is investigating issues with network performance for some customers in the Virgina area. We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Mar 27, 2025 - 20:57 UTC
This incident affected: North America (Ashburn, VA, United States - (IAD)) and Cloudflare Sites and Services (Network).