Cloudflare System Status

Cloudflare Turnstile and Challenges: Ongoing issues in Estonia - (TLL)

Incident Report for Cloudflare

Resolved

We have identified and implemented an effective fix for this issue. This incident is now resolved.
Posted Mar 18, 2025 - 17:04 UTC

Investigating

Cloudflare is aware of, and investigating an issue which potentially impacts multiple customers: an increased rate of Turnstile and Challenges errors are being observed in Estonia - (TLL).
Further detail will be provided as more information becomes available.
Posted Mar 18, 2025 - 15:55 UTC
This incident affected: Cloudflare Sites and Services (Challenge Platform, Turnstile).