Cloudflare System Status

Registrar is currently experiencing new registration failures.
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 14, 2023 - 00:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2023 - 00:35 UTC
Investigating
Customer trying new domain name registration might fail and domain will fail to register resulting on a 404 in the dashboard.

Checking WHOIS will confirm whether the domain was actually registered or not.

This is currently under investigation and more updates to come shortly.
Posted Apr 14, 2023 - 00:17 UTC
This incident affected: Cloudflare Sites and Services (Registrar).