Cloudflare System Status

Delayed DNS updates in Hong Kong
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 03, 2016 - 11:16 UTC
Monitoring
The problem has been resolved and we are currently monitoring the situation.
Posted Mar 03, 2016 - 10:34 UTC
Investigating
We're reviewing delays for propagating DNS changes to Hong Kong.

We will update as we know more.
Posted Mar 03, 2016 - 10:22 UTC
This incident affected: Asia (Hong Kong - (HKG)).