Cloudflare System Status

Network Performance Issues in Chicago (ORD)
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 05:17 UTC
Monitoring
Cloudflare has identifed Network Performance issues in Chicago (ORD)

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Apr 25, 2024 - 03:12 UTC